Tuesday, November 17, 2015

Resolving Some of Exchange 2013 Uninstall Problems

Hi folks,

In this post I would love to share with you on the issues that I had when uninstalling on Exchange 2013 server. The server version was Exchange 2013 CU9 and it was multi-role server. As you may know Exchange 2013 mailbox server is a combination of all Exchange 2010 server roles.

To uninstall Exchange 2013 binary files I have navigated to the installation files and executed the following command:

setup.exe /m:Uninstall /IAcceptExchangeServerLicenseTerms

So when I launched uninstall all prereqs proved to be successful and installation started. Mailbox services were uninstalled straight away. When the UM services uninstall turn came it prompted me with the following window:

Exchange 2013 uninstall program in order to uninstall UM services component was looking to the following files:
- MSSpeech_SR_en-US_TELE.msi
- MSSpeech_TTS_en-US_Helen.msi

These MSI files belong to UCMA 4.0 which is a prereq for Exchange 2013 installation. When UCMA is being installed it creates the following folder in the Temp folder within end user's profile under which the Exchange 2013 installation is happening. For example: C:\Users\ExchAdmin\AppData\Local\Temp\2\UcmaRuntimeSetup.  After UCMA installation UcmaRuntimeSetup folder is being removed by installation program. To resolve this I had to install UCMA 4.0 on the other computer. I didn't rush to click Next button before file installation to take place. I have copied the whole UcmaRuntimeSetup folder under my account's user profile Temp folder and re-ran the uninstall again.

As you can see UM uninstall completed successfully. 




However I faced another issue when CAS component was being uninstalled I faced the following error displayed both in screen and logged to the Exchange setup log.


This is where this article came to help. The problem was with IIS not being able to load exppw.dll module. You can read more details about it in the article itself. As long as I was concerned I had to edit configuration file for IIS located at C:\Windows\System32\inetsrv\config\applicationHost.config  and add the following into the <globalModules> section:

<add name="exppw" image="C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\Owa\auth\exppw.dll" />

I have executed IISRESET and installation continued for CAS component was successfully uninstall.

First I encountered the following error when uninstalling Front-End Transport component



This is because Microsoft Exchange Active Directory Topology wouldn't stop because of FIP-FS 
Microsoft Filtering Management Service not being properly removed from the server. It's state was running while startup type was set to Disable. After stopping Microsoft Filtering Management Service I was able to do the same with Microsoft Exchange Active Directory Topology.

Uninstall process moved forward and stumbled over the missing cafe_exppw module in IIS.

I had to go back to C:\Windows\System32\inetsrv\config\applicationHost.config and added the following into the </globalModules>  section:

<add name="cafe_exppw" image="D:\Program Files\Microsoft\Exchange Server\FrontEnd\HttpProxy\bin\exppw.dll" />

After this I ran IISRESET and restarted uninstall program. Front-End CAS component has been successfully uninstalled.

Finally uninstall of the language packs went successfully and server has been sucessfully removed from the AD so there was no need to scrapping it out manually

Enjoy!